PT-2022-5220
CVE-2022-2129
·
تاريخ النشر
2022-06-16
·
تاريخ التحديث
2026-10-16
الوصف من
CVSS 2.0
9.3
عاليةالمقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
vim versions prior to 8.2
Description
The issue is related to an out-of-bounds write in the vim regsub both function of the regexp.c component in the Vim text editor. This can allow a remote attacker to access confidential data, compromise its integrity, and cause a denial of service.
Recommendations
For versions prior to 8.2, update to version 8.2 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
vim regsub both function in the regexp.c component until a patch is available.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾