PT-2022-5380
CVE-2021-46848
·
تاريخ النشر
2022-08-24
·
تاريخ التحديث
2026-10-16
الوصف من
CVSS 2.0
9.4
حرجةالمقاييسAV:N/AC:L/Au:N/C:C/I:N/A:C
Name of the Vulnerable Software and Affected Versions
GNU Libtasn1 versions prior to 4.19.0
Description
The issue is related to an off-by-one error in the
asn1 encode simple der() function of the Libtasn1 library. This can be exploited by a remote attacker to disclose protected information or cause a denial of service by sending specially crafted data to the application. The error is due to an incorrect array size check, specifically an ETYPE OK check.Recommendations
For GNU Libtasn1 versions prior to 4.19.0, update to version 4.19.0 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
asn1 encode simple der() function until a patch is available.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾