PT-2022-5709
CVE-2022-3328
·
تاريخ النشر
2022-11-30
·
تاريخ التحديث
2024-06-14
الوصف من
CVSS 4.0
9.0
حرجةالمقاييسAV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
Name of the Vulnerable Software and Affected Versions
snapd versions prior to 2.57.6
snap-confine versions prior to 2.57.6
Description
The issue is related to a race condition in the
must mkdir and open with perms() function of the snap-confine utility. This vulnerability can be exploited to elevate privileges or execute arbitrary code. The problem is associated with synchronization errors when using a shared resource, also known as a "race condition".Recommendations
For versions prior to 2.57.6, update to version 2.57.6 or later to resolve the issue.
As a temporary workaround, consider disabling the
must mkdir and open with perms() function until a patch is available.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾