PT-2022-9366

CVE-2021-23154

·

تاريخ النشر

2022-01-10

·

تاريخ التحديث

2022-01-18

الوصف من

CVSS 2.0
9.3
عالية
المقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Lens versions prior to 5.3.4
Description The issue allows custom helm chart configuration to create helm commands from string concatenation of provided arguments, which are then executed in the user's shell. This can be exploited by providing arguments that cause arbitrary shell commands to run on the system.
Recommendations For Lens versions prior to 5.3.4, update to version 5.3.4 or later to resolve the issue. As a temporary workaround, consider restricting the use of custom helm chart configuration to minimize the risk of exploitation. Avoid providing arguments that could be used to execute arbitrary shell commands.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾