PT-2023-1017
CVE-2023-0054
·
تاريخ النشر
2023-01-04
·
تاريخ التحديث
2026-10-16
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Vim versions prior to 9.0.1145
Description
The issue is related to an out-of-bounds write in the Vim text editor, specifically in the do string sub() function (eval.c), which is caused by a boundary error when processing untrusted input data. This can allow an attacker to execute arbitrary code.
Recommendations
For versions prior to 9.0.1145, update to version 9.0.1191 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the do string sub() function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾