PT-2023-1147

CVE-2023-23596

·

تاريخ النشر

2023-01-20

·

تاريخ التحديث

2023-01-30

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions NGINX Proxy Manager versions 2.9.19 and earlier
Description The issue allows OS command injection when creating an access list. The backend builds an htpasswd file with crafted username and/or password input that is concatenated without any validation, and is directly passed to the exec command, potentially allowing an authenticated attacker to execute arbitrary commands on the system.
Recommendations For NGINX Proxy Manager versions 2.9.19 and earlier, update to a version later than 2.9.19 to resolve the issue. As a temporary workaround, consider restricting access to the exec command and validating any user input for the username and password variables to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾