PT-2023-12842

CVE-2022-25967

·

تاريخ النشر

2023-01-30

·

تاريخ التحديث

2025-03-27

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions eta versions prior to 2.0.0
Description The issue allows for Remote Code Execution (RCE) by overwriting template engine configuration variables with view options received from The Express render API. This is exploitable only for users who are rendering templates with user-defined data.
Recommendations For versions prior to 2.0.0, update to version 2.0.0 or later to resolve the issue. As a temporary workaround, consider restricting the rendering of templates with user-defined data until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-MF6X-HRGR-658F
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾