PT-2023-15025
CVE-2022-4678
·
تاريخ النشر
2023-02-13
·
تاريخ التحديث
2025-03-21
الوصف من
CVSS 3.1
5.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
TemplatesNext ToolKit WordPress plugin versions prior to 3.2.8
Description
The issue concerns the TemplatesNext ToolKit WordPress plugin, which does not properly validate and escape certain shortcode attributes before outputting them in a page or post. This could allow users with the contributor role or higher to perform Stored Cross-Site Scripting attacks.
Recommendations
For versions prior to 3.2.8, update to version 3.2.8 or later to resolve the issue. As a temporary workaround, consider restricting the use of shortcodes to minimize the risk of exploitation. Avoid using unvalidated and unescaped shortcode attributes in pages or posts until the issue is resolved.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾