PT-2023-17147

CVE-2023-1651

·

تاريخ النشر

2023-05-08

·

تاريخ التحديث

2023-05-11

الوصف من

CVSS 3.1
5.4
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions AI ChatBot WordPress plugin versions prior to 4.4.9
Description The issue concerns a lack of authorization and CSRF protection in the AJAX action for updating OpenAI settings. This allows any authenticated user, such as a subscriber, to modify these settings. Additionally, the lack of proper escaping of settings can lead to Stored XSS.
Recommendations For versions prior to 4.4.9, update to version 4.4.9 or later to resolve the issue. As a temporary workaround, consider restricting access to the AJAX action responsible for updating OpenAI settings to prevent unauthorized changes.
قابلية الاستغلال
استغلال
إصلاح
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾