PT-2023-18355
CVE-2023-2195
·
تاريخ النشر
2023-05-16
·
تاريخ التحديث
2023-05-25
الوصف من
CVSS 3.1
4.3
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Jenkins Code Dx Plugin versions 3.1.0 and earlier
Description
A cross-site request forgery (CSRF) vulnerability allows attackers to connect to an attacker-specified URL. The issue arises from the lack of permission checks in several HTTP endpoints, which can be exploited by attackers with Overall/Read permission. These endpoints also do not require POST requests, contributing to the vulnerability.
Recommendations
For Jenkins Code Dx Plugin versions 3.1.0 and earlier, update to version 4.0.0, which requires POST requests and the appropriate permissions for the affected HTTP endpoints. As a temporary workaround, consider restricting access to the affected HTTP endpoints to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾