PT-2023-18673

CVE-2023-22731

·

تاريخ النشر

2023-01-17

·

تاريخ التحديث

2026-10-24

الوصف من

CVSS 3.1
9.9
حرجة
المقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Shopware versions prior to 6.4.18.1
Description The issue affects Shopware, an open source commerce platform based on Symfony Framework and Vue js. In a Twig environment without the Sandbox extension, it is possible to refer to PHP functions in twig filters like map, filter, sort. This allows a template to call any global PHP function and thus execute arbitrary code. The attacker must have access to a Twig environment in order to exploit this issue.
Recommendations For versions prior to 6.4.18.1, update to version 6.4.18.1 or later to resolve the issue. For users of major versions 6.1, 6.2, and 6.3, consider installing a plugin that provides the necessary security measures as a temporary workaround until a full update can be performed. As a general best practice, ensure that the Sandbox extension is integrated into the Twig environment to prevent similar issues in the future.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-93CW-F5JJ-X85W
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾