PT-2023-2291
CVE-2023-28879
·
تاريخ النشر
2023-03-31
·
تاريخ التحديث
2026-10-17
الوصف من
CVSS 2.0
10
حرجةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Artifex Ghostscript versions through 10.01.0
Description
The issue is related to a buffer overflow in the PostScript interpreter, specifically affecting the
BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode functions in base/sbcp.c. This occurs when the write buffer is filled to one byte less than full and an attempt is made to write an escaped character, resulting in two bytes being written. The exploitation of this issue may allow a remote attacker to execute arbitrary code.Recommendations
For Artifex Ghostscript versions through 10.01.0, update to version 10.01.1 or later to resolve the issue. As a temporary workaround, consider restricting the use of the affected functions
BCPEncode, BCPDecode, TBCPEncode, and TBCPDecode until a patch is available.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾