PT-2023-23117
CVE-2023-31039
·
تاريخ النشر
2023-05-08
·
تاريخ التحديث
2026-10-24
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Apache bRPC versions prior to 1.5.0
Description
A security issue in Apache bRPC allows attackers to execute arbitrary code via the
pid file parameter in ServerOptions. This can be exploited by an attacker who can influence the pid file parameter when the bRPC server is started, resulting in arbitrary code execution with the permissions of the bRPC process.Recommendations
For Apache bRPC versions prior to 1.5.0, upgrade to bRPC version 1.5.0 or later.
If upgrading is difficult, apply the patch available at https://github.com/apache/brpc/pull/2218 as a temporary solution.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾