PT-2023-2558
CVE-2023-24607
·
تاريخ النشر
2023-02-20
·
تاريخ التحديث
2025-09-28
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Qt versions 5.x through 5.15.12
Qt versions 6.x through 6.2.7
Qt versions 6.3.x through 6.4.2
Description
The issue is related to the incorrect cleanup or release of resources in the SQL ODBC plugin of the Qt framework. This can be exploited by a remote attacker to cause a denial of service using specially crafted data. The vulnerability is triggered when the SQL ODBC driver plugin is used and the size of SQLTCHAR is 4.
Recommendations
For Qt versions 5.x through 5.15.12, update to version 5.15.13 or later.
For Qt versions 6.x through 6.2.7, update to version 6.2.8 or later.
For Qt versions 6.3.x through 6.4.2, update to version 6.4.3 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾