PT-2023-25876

CVE-2023-37273

·

تاريخ النشر

2023-07-13

·

تاريخ التحديث

2026-02-24

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:L
Name of the Vulnerable Software and Affected Versions Auto-GPT versions prior to 0.4.3
Description The issue arises from the use of a different docker-compose.yml file when running Auto-GPT by cloning the git repo and executing docker compose run auto-gpt in the repo root. This file mounts itself into the docker container without write protection, allowing malicious custom python code executed via the execute python file and execute python code commands to overwrite the docker-compose.yml file. This can lead to abuse and gain control of the host system the next time Auto-GPT is started.
Recommendations For versions prior to 0.4.3, update to version 0.4.3 to resolve the issue. As a temporary workaround, consider disabling the execute python file and execute python code commands until the update is applied. Restrict access to the docker-compose.yml file to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-X5GJ-2CHR-4CH6
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾