PT-2023-31978

CVE-2023-5255

·

تاريخ النشر

2023-10-03

·

تاريخ التحديث

2025-11-20

الوصف من

CVSS 3.1
4.4
متوسطة
المقاييسAV:N/AC:H/PR:H/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions Puppet Bolt versions prior to 3.27.4 Puppet Server (affected versions not specified)
Description A flaw exists in Puppet Server for certificates that utilize the auto-renew feature, which prevents the certificates from being revoked. Additionally, in Puppet Bolt, a path to escalate privileges was identified.
Recommendations For Puppet Bolt versions prior to 3.27.4, update to version 3.27.4 or later to resolve the privilege escalation issue. For Puppet Server, at the moment, there is no information about a newer version that contains a fix for this vulnerability.
قابلية الاستغلال
استغلال
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-289M-2964-F8Q5
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾