PT-2023-3580
CVE-2023-32763
·
تاريخ النشر
2023-05-22
·
تاريخ التحديث
2026-09-18
الوصف من
CVSS 2.0
7.8
عاليةالمقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
Qt versions prior to 5.15.15
Qt versions 6.x prior to 6.2.9
Qt versions 6.3.x through 6.5.x prior to 6.5.1
Description
The issue is related to a buffer overflow in the QTextLayout component of the Qt framework when rendering a SVG file with an image inside it. This can be triggered by a specially crafted SVG file, allowing a remote attacker to cause a denial of service.
Recommendations
For Qt versions prior to 5.15.15, update to version 5.15.15 or later.
For Qt versions 6.x prior to 6.2.9, update to version 6.2.9 or later.
For Qt versions 6.3.x through 6.5.x prior to 6.5.1, update to version 6.5.1 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾