PT-2023-4935
CVE-2023-39510
·
تاريخ النشر
2023-09-05
·
تاريخ التحديث
2026-09-30
الوصف من
CVSS 2.0
8.5
عاليةالمقاييسAV:N/AC:L/Au:S/C:C/I:C/A:N
Name of the Vulnerable Software and Affected Versions
Cacti versions prior to 1.2.25
Description
Cacti is an open source operational monitoring and fault management framework. Affected versions are subject to a Stored Cross-Site-Scripting (XSS) Vulnerability that allows an authenticated user to poison data stored in the cacti 's database. These data will be viewed by administrative cacti accounts and execute JavaScript code in the victim's browser at view-time. The
reports admin.php script displays reporting information about graphs, devices, data sources etc. An adversary that is able to configure a malicious Device name can deploy a stored XSS attack against any user of the same (or broader) privileges. This configuration occurs through "http:///cacti/host.php", while the rendered malicious payload is exhibited at "http:///cacti/reports admin.php" when a graph with the maliciously altered device name is linked to the report.Recommendations
To resolve the issue, upgrade to version 1.2.25 or later.
For versions prior to 1.2.25, users unable to update should manually filter HTML output.
As a temporary workaround, consider restricting access to the
http://<HOST>/cacti/host.php and http://<HOST>/cacti/reports admin.php endpoints to minimize the risk of exploitation.
Additionally, restrict the ability to configure device names in cacti to only trusted users with the General Administration>Sites/Devices/Data permissions.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾