PT-2023-5107

CVE-2023-4738

·

تاريخ النشر

2023-09-02

·

تاريخ التحديث

2025-03-30

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions vim versions prior to 9.0.1848
Description The issue is a heap-based buffer overflow in the vim text editor, specifically in the vim regsub both function, caused by a dynamic memory buffer overflow. This can allow an attacker to execute arbitrary code.
Recommendations For versions prior to 9.0.1848, update to version 9.0.1848 or later to resolve the issue. As a temporary workaround, consider restricting the use of the vim regsub both function until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2023-5538
ALT-PU-2023-5553
ALT-PU-2023-5877
ALT-PU-2023-5879
AZL-28661
DLA-4097-1
OESA-2023-1653
OPENSUSE-SU-2023_3955-1
OPENSUSE-SU-2023_4557-1
OPENSUSE-SU-2024:13226-1
SUSE-SU-2023:3942-1
SUSE-SU-2023:3955-1
SUSE-SU-2023:4557-1
USN-6452-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾