PT-2023-8905
CVE-2023-46118
·
تاريخ النشر
2023-10-23
·
تاريخ التحديث
2026-09-25
الوصف من
CVSS 2.0
6.1
متوسطةالمقاييسAV:N/AC:L/Au:M/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions
RabbitMQ versions prior to 3.11.24
RabbitMQ versions prior to 3.12.7
Description
The issue is related to the HTTP API of RabbitMQ, a multi-protocol messaging and streaming broker, which did not enforce an HTTP request body limit. This made it vulnerable to denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish very large messages over the HTTP API, causing the target node to be terminated by an "out-of-memory killer"-like mechanism.
Recommendations
For RabbitMQ versions prior to 3.11.24, update to version 3.11.24 or later to resolve the issue.
For RabbitMQ versions prior to 3.12.7, update to version 3.12.7 or later to resolve the issue.
As a temporary workaround, consider restricting access to the HTTP API to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾