PT-2024-10752

CVE-2019-25221

·

تاريخ النشر

2024-12-13

·

تاريخ التحديث

2024-12-15

الوصف من

CVSS 3.1
6.5
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Responsive Filterable Portfolio plugin for WordPress versions 1.0.8 and earlier
Description The issue is related to SQL Injection via the id parameter due to insufficient escaping on the user-supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Recommendations For Responsive Filterable Portfolio plugin for WordPress versions 1.0.8 and earlier, update to a version later than 1.0.8 to mitigate the risk of SQL Injection. As a temporary workaround, consider restricting access to the id parameter in the affected API endpoint until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾