PT-2024-15515

CVE-2024-0381

·

تاريخ النشر

2024-01-18

·

تاريخ التحديث

2024-01-24

الوصف من

CVSS 3.1
6.4
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions WP Recipe Maker plugin for WordPress versions up to, and including, 9.1.0
Description The issue is related to Stored Cross-Site Scripting via the use of the tag attribute in the "wprm-recipe-name", "wprm-recipe-date", and "wprm-recipe-counter" shortcodes. This allows authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For WP Recipe Maker plugin for WordPress versions up to, and including, 9.1.0, update to a version later than 9.1.0 to resolve the issue. As a temporary workaround, consider disabling the use of the tag attribute in the "wprm-recipe-name", "wprm-recipe-date", and "wprm-recipe-counter" shortcodes until a patch is available. Restrict access to these shortcodes to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾