PT-2024-16000
CVE-2024-10056
·
تاريخ النشر
2024-12-05
·
تاريخ التحديث
2024-12-05
الوصف من
CVSS 3.1
6.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Contact Form Builder by vcita plugin for WordPress versions up to, and including, 4.10.4
Description
The issue is related to Stored Cross-Site Scripting via the plugin's livesite-pay shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 4.10.4, update to a version later than 4.10.4 to resolve the issue. As a temporary workaround, consider restricting access to the livesite-pay shortcode to minimize the risk of exploitation. Additionally, restrict contributor-level access and above to authorized personnel only.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾