PT-2024-16227
CVE-2024-10374
·
تاريخ النشر
2024-10-25
·
تاريخ التحديث
2024-10-31
الوصف من
CVSS 3.1
6.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
WP-Members Membership Plugin versions up to, and including, 3.4.9.5
Description
The issue is related to Stored Cross-Site Scripting via the plugin's
wpmem loginout shortcode due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.Recommendations
For versions up to, and including, 3.4.9.5, update to a version later than 3.4.9.5 to resolve the issue. As a temporary workaround, consider restricting access to the
wpmem loginout shortcode to minimize the risk of exploitation. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾