PT-2024-16803

CVE-2024-1118

·

تاريخ النشر

2024-02-07

·

تاريخ التحديث

2024-02-10

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Podlove Subscribe button plugin for WordPress versions up to, and including, 1.3.10
Description The issue is related to a UNION-based SQL Injection vulnerability via the button attribute of the podlove-subscribe-button shortcode. This vulnerability is caused by insufficient escaping on the user-supplied parameter and lack of sufficient preparation on the existing SQL query. As a result, authenticated attackers with contributor-level access and above can append additional SQL queries into already existing queries, potentially extracting sensitive information from the database.
Recommendations For versions up to, and including, 1.3.10, update to a version later than 1.3.10 to resolve the issue. As a temporary workaround, consider restricting access to the podlove-subscribe-button shortcode to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾