PT-2024-16840

CVE-2024-11225

·

تاريخ النشر

2024-11-21

·

تاريخ التحديث

2024-11-22

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions The Premium Packages – Sell Digital Products Securely plugin for WordPress versions up to, and including, 5.9.3
Description The issue arises from the use of add query arg without proper escaping on the URL, allowing unauthenticated attackers to inject arbitrary web scripts in pages. This can be executed if a user is tricked into performing an action, such as clicking on a link. The attackers can inject scripts by manipulating the URL, which can lead to the execution of malicious code.
Recommendations For versions up to, and including, 5.9.3, update to a version higher than 5.9.3 to resolve the issue. As a temporary workaround, consider restricting access to URLs that use the add query arg function until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾