PT-2024-17219

CVE-2024-11730

·

تاريخ النشر

2024-12-06

·

تاريخ التحديث

2024-12-06

الوصف من

CVSS 3.1
6.5
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions KiviCare – Clinic & Patient Management System (EHR) plugin for WordPress versions prior to 3.6.5
Description The issue is related to SQL injection through the sort[] parameter of the "static data list" AJAX action. This vulnerability is due to insufficient escaping of the user-supplied parameter and lack of sufficient preparation in the existing SQL query. Authenticated attackers with doctor/receptionist-level access and above can append additional SQL queries to existing ones, allowing them to extract sensitive information from the database.
Recommendations For versions prior to 3.6.5, update to version 3.6.5 or later to resolve the issue. As a temporary workaround, consider restricting access to the static data list AJAX action to minimize the risk of exploitation. Avoid using the sort[] parameter in the affected AJAX endpoint until the issue is resolved.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾