PT-2024-17270

CVE-2024-11814

·

تاريخ النشر

2024-12-04

·

تاريخ التحديث

2024-12-04

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Additional Custom Order Status for WooCommerce plugin for WordPress versions up to, and including, 1.6.0
Description The issue is related to Reflected Cross-Site Scripting due to insufficient input sanitization and output escaping. This allows unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action, such as clicking on a link. The vulnerable parameters are wfwp wcos delete finished, wfwp wcos delete fallback finished, wfwp wcos delete fallback orders updated, and wfwp wcos delete fallback status.
Recommendations For versions up to, and including, 1.6.0, update to a version higher than 1.6.0 to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable parameters wfwp wcos delete finished, wfwp wcos delete fallback finished, wfwp wcos delete fallback orders updated, and wfwp wcos delete fallback status until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾