PT-2024-18955

CVE-2024-21543

·

تاريخ النشر

2024-12-13

·

تاريخ التحديث

2025-03-24

الوصف من

CVSS 3.1
7.1
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N
Name of the Vulnerable Software and Affected Versions djoser versions prior to 2.3.0
Description The issue allows for Authentication Bypass when the authenticate() function fails, causing the system to fall back to querying the database directly. This grants access to users with valid credentials and bypasses custom authentication checks, including two-factor authentication, LDAP validations, or requirements from configured AUTHENTICATION BACKENDS.
Recommendations For versions prior to 2.3.0, update to version 2.3.0 or later to resolve the issue. As a temporary workaround, consider disabling the authenticate() function until a patch is available. Restrict access to custom authentication modules to minimize the risk of exploitation. Avoid relying solely on the AUTHENTICATION BACKENDS for authentication until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-V49P-M6GH-747C
DLA-4060-1
PYSEC-2024-158
USN-7354-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾