PT-2024-20722
CVE-2024-2506
·
تاريخ النشر
2024-06-01
·
تاريخ التحديث
2024-06-03
الوصف من
CVSS 3.1
6.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Popup Builder – Create highly converting, mobile friendly marketing popups. plugin for WordPress versions up to, and including, 4.2.7
Description
The issue is related to Stored Cross-Site Scripting via the custom JS functionality due to insufficient input sanitization and output escaping on user supplied attributes. This allows authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations
For versions up to, and including, 4.2.7, update to a version higher than 4.2.7 to resolve the issue. As a temporary workaround, consider restricting access to the custom JS functionality to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾