PT-2024-21844

CVE-2024-27355

·

تاريخ النشر

2023-08-25

·

تاريخ التحديث

2026-09-15

الوصف من

CVSS 2.0
7.8
عالية
المقاييسAV:N/AC:L/Au:N/C:N/I:N/A:C
Name of the Vulnerable Software and Affected Versions phpseclib versions 1.x through 1.0.22 phpseclib versions 2.x through 2.0.46 phpseclib versions 3.x through 3.0.35
Description An issue was discovered in phpseclib when processing the ASN.1 object identifier of a certificate. A sub identifier may be provided that leads to a denial of service due to CPU consumption for decodeOID.
Recommendations For phpseclib versions 1.x through 1.0.22, update to version 1.0.23 or later. For phpseclib versions 2.x through 2.0.46, update to version 2.0.47 or later. For phpseclib versions 3.x through 3.0.35, update to version 3.0.36 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-F2QX-66WF-WVVX
GHSA-JR22-8QGM-4Q87
DLA-3749-1
DLA-3750-1
OPENSUSE-SU-2026:10920-1
USN-7404-1
USN-8769-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾