PT-2024-22387
CVE-2024-2831
·
تاريخ النشر
2024-05-02
·
تاريخ التحديث
2024-05-11
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
The Calendar plugin for WordPress versions up to, and including, 1.3.14
Description
The issue arises from insufficient escaping on the user-supplied parameter and lack of sufficient preparation on the existing SQL query in the plugin's shortcodes. This allows authenticated attackers with contributor access or higher to append additional SQL queries into already existing queries, potentially extracting sensitive information from the database.
Recommendations
For versions up to, and including, 1.3.14, update to a version higher than 1.3.14 to resolve the issue.
As a temporary workaround, consider restricting access to the shortcodes or limiting contributor access to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾