PT-2024-2532
CVE-2024-28085
·
تاريخ النشر
2024-03-27
·
تاريخ التحديث
2026-10-07
الوصف من
CVSS 2.0
6.2
متوسطةالمقاييسAV:L/AC:L/Au:S/C:C/I:C/A:N
Name of the Vulnerable Software and Affected Versions
util-linux versions prior to 2.40
Description
The
wall command in util-linux versions through 2.40 does not properly filter escape sequences received from command line arguments. This allows a local attacker to potentially inject escape sequences, which could lead to information disclosure or, in some scenarios, account takeover. The vulnerability has been present for over 11 years. A fix was initially released but did not fully address the issue, leading to a subsequent update that removes the setgid permission bit from the wall and write utilities.Recommendations
Upgrade to util-linux version 2.40 or later.
Remove the setgid permission bit from the
wall and write utilities.
Consider disabling the wall command.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾