PT-2024-2537

CVE-2024-27758

·

تاريخ النشر

2024-03-06

·

تاريخ التحديث

2026-10-04

الوصف من

CVSS 3.1
8.4
عالية
المقاييسAV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions RPyC versions prior to 6.0.0
Description The issue is related to the netref component of the RPyC Python library, which has an incorrect security check for standard elements. This can allow a remote attacker to execute arbitrary code by crafting a class that exploits the vulnerability when a server exposes a method calling the array attribute for a client-provided netref, such as np.array(client netref).
Recommendations For versions prior to 6.0.0, update to version 6.0.0 or later to resolve the issue. As a temporary workaround, consider restricting access to methods that call the array attribute for client-provided netrefs until a patch is applied. Avoid using the np.array(client netref) function in affected API endpoints until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-H5CG-53G7-GQJW
OPENSUSE-SU-2024:0082-1
OPENSUSE-SU-2024:13768-1
OPENSUSE-SU-2026:12040-1
PYSEC-2024-44
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾