PT-2024-2675
CVE-2024-23171
·
تاريخ النشر
2024-01-12
·
تاريخ التحديث
2025-06-19
الوصف من
CVSS 2.0
5.5
متوسطةالمقاييسAV:N/AC:L/Au:S/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions
MediaWiki versions prior to 1.35.14
MediaWiki versions 1.36.x through 1.39.x before 1.39.6
MediaWiki versions 1.40.x before 1.40.2
Description
The issue is related to the CampaignEvents extension in MediaWiki, which is associated with improper input neutralization during web page creation. This can allow a remote attacker to perform cross-site scripting attacks. The Special:EventDetails page is vulnerable to XSS via the x-xss language setting for internationalization.
Recommendations
For MediaWiki versions prior to 1.35.14, update to version 1.35.14 or later.
For MediaWiki versions 1.36.x through 1.39.x before 1.39.6, update to version 1.39.6 or later.
For MediaWiki versions 1.40.x before 1.40.2, update to version 1.40.2 or later.
As a temporary workaround, consider restricting access to the Special:EventDetails page until a patch is available.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾