PT-2024-28954

CVE-2024-40633

·

تاريخ النشر

2024-07-17

·

تاريخ التحديث

2024-07-18

الوصف من

CVSS 4.0
8.7
عالية
المقاييسAV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions Sylius versions prior to 1.12.19 Sylius versions prior to 1.13.4
Description A security issue was discovered in the "/api/v2/shop/adjustments/{id}" endpoint, which retrieves order adjustments based on incremental integer IDs. The issue allows an attacker to enumerate valid adjustment IDs and retrieve order tokens. Using these tokens, an attacker can access guest customer order details, including sensitive guest customer information.
Recommendations For Sylius versions prior to 1.12.19, upgrade to version 1.12.19 or above. For Sylius versions prior to 1.13.4, upgrade to version 1.13.4 or above. As a temporary workaround for users unable to upgrade, alter the configuration to mitigate this issue by creating a "config/api platform/Adjustment.yaml" file with the specified settings or by modifying the "config/api platform/Adjustment.xml" file to change the "shop get" operation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-55RF-8Q29-4G43
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾