PT-2024-2954
CVE-2024-30260
·
تاريخ النشر
2024-04-04
·
تاريخ التحديث
2026-08-25
الوصف من
CVSS 2.0
4.6
متوسطةالمقاييسAV:N/AC:H/Au:S/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions
Undici versions prior to 5.28.4
Undici versions prior to 6.11.1
Description
The issue is related to the Undici HTTP/1.1 client for Node.js, which has a flaw in its authorization procedure. Specifically, Undici clears Authorization and Proxy-Authorization headers for
fetch(), but fails to do so for undici.request(). This could potentially allow a remote attacker to execute arbitrary code.Recommendations
For versions prior to 5.28.4, update to version 5.28.4 or later.
For versions prior to 6.11.1, update to version 6.11.1 or later.
As a temporary workaround, consider using
fetch() instead of undici.request().
Alternatively, disable maxRedirections to minimize the risk of exploitation.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾