PT-2024-2956
CVE-2024-30261
·
تاريخ النشر
2024-04-04
·
تاريخ التحديث
2026-08-19
الوصف من
CVSS 3.1
3.5
منخفضةالمقاييسAV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Undici versions prior to 5.28.4
Undici versions prior to 6.11.1
Description
The issue is related to insufficient access control in the Undici HTTP/1.1 client for Node.js, allowing a remote attacker to execute arbitrary code by altering the
integrity option passed to fetch(). This enables fetch() to accept tampered requests as valid.Recommendations
For versions prior to 5.28.4, update to version 5.28.4 or later.
For versions prior to 6.11.1, update to version 6.11.1 or later.
As a temporary workaround, ensure that the
integrity option cannot be tampered with to minimize the risk of exploitation.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾