PT-2024-29581

CVE-2024-41815

·

تاريخ النشر

2024-07-26

·

تاريخ التحديث

2024-10-08

الوصف من

CVSS 3.1
7.4
عالية
المقاييسAV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Starship versions 1.0.0 through 1.19.x
Description Starship is a cross-shell prompt that has undocumented and unpredictable shell expansion and/or quoting rules, making it easy to accidentally cause shell injection when using custom commands with starship in bash. This issue only affects users with custom commands, so the scope is limited, and without knowledge of others' commands, it could be hard to successfully target someone.
Recommendations For versions prior to 1.20.0, update to version 1.20.0 to fix the vulnerability. As a temporary workaround, consider avoiding the use of custom commands that print out information from potentially untrusted or unverified sources until a patch is available. Restrict access to custom commands to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-VX24-X4MV-VWR5
ALT-PU-2024-13365
RUSTSEC-2024-0446
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾