PT-2024-29695
CVE-2024-4203
·
تاريخ النشر
2024-05-02
·
تاريخ التحديث
2025-01-15
الوصف من
CVSS 3.1
5.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
Premium Addons Pro for Elementor plugin for WordPress versions up to, and including, 4.10.30
Description
The issue is related to Stored Cross-Site Scripting via the maps widget due to insufficient input sanitization and output escaping on user-supplied attributes. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The issue only affects sites running the premium version of the plugin.
Recommendations
For versions up to, and including, 4.10.30, update to a version higher than 4.10.30 to resolve the issue. As a temporary workaround, consider restricting access to the maps widget for users with contributor-level access and above until a patch is available. Additionally, restrict the use of user-supplied attributes in the maps widget to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾