PT-2024-29892

CVE-2024-42356

·

تاريخ النشر

2024-08-08

·

تاريخ التحديث

2024-08-15

الوصف من

CVSS 4.0
8.7
عالية
المقاييسAV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions Shopware versions prior to 6.5.8.13 Shopware versions prior to 6.6.5.1
Description The issue concerns the context variable injected into almost any Twig Template, allowing access to current language and currency information. The context object can switch the scope of the Context as a helper with a callable function, which can be called from Twig. This allows calling any statically callable PHP function/method from Twig. Exploitation requires access to Administration, using Mail templates or App Scripts.
Recommendations Update to Shopware 6.5.8.13 to receive a patch. Update to Shopware 6.6.5.1 to receive a patch. For older versions of 6.1, 6.2, 6.3, and 6.4, corresponding security measures are available via a plugin.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-35JP-8CGG-P4WJ
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾