PT-2024-30605
CVE-2024-4362
·
تاريخ النشر
2024-05-22
·
تاريخ التحديث
2025-03-24
الوصف من
CVSS 3.1
6.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
SiteOrigin Widgets Bundle plugin for WordPress versions up to, and including, 1.60.0
Description
The issue arises from insufficient input sanitization and output escaping on user-supplied attributes in the
siteorigin widget shortcode. This allows authenticated attackers with contributor-level access and above to inject arbitrary web scripts in pages. The injected scripts will execute whenever a user accesses the injected page.Recommendations
For versions up to, and including, 1.60.0, update to a version higher than 1.60.0 to resolve the issue.
As a temporary workaround, consider restricting access to the
siteorigin widget shortcode for users with contributor-level access and above until a patch is available. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾