PT-2024-34043
CVE-2024-50208
·
تاريخ النشر
2024-10-08
·
تاريخ التحديث
2026-10-19
الوصف من
CVSS 4.0
8.5
عاليةالمقاييسAV:L/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
Name of the Vulnerable Software and Affected Versions:
Linux kernel versions prior to 6.6.61
Description:
A bug in the Linux kernel has been resolved, specifically in the RDMA/bnxt re module, which fixes a bug while setting up Level-2 PBL pages. This bug could lead to memory corruption when setting up Level-2 PBL pages for non-MR resources when
num pages is greater than 256K. The current logic assumes multiple pages, resulting in invalid memory access after 256K PBL entries in the PDE.Recommendations:
For Linux kernel versions prior to 6.6.61, update to version 6.6.61 or later to resolve the issue. As a temporary workaround, consider restricting access to the RDMA/bnxt re module until a patch is available. Avoid using the
num pages variable with values greater than 256K in the affected API endpoints until the issue is resolved. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾