PT-2024-35010
CVE-2024-5188
·
تاريخ النشر
2024-06-06
·
تاريخ التحديث
2024-06-11
الوصف من
CVSS 3.1
6.4
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions
The Essential Addons for Elementor – Best Elementor Templates, Widgets, Kits & WooCommerce Builders plugin for WordPress versions up to, and including, 5.9.22
Description
The issue is related to Stored Cross-Site Scripting via the
get manual calendar events function due to insufficient input sanitization and output escaping. This allows authenticated attackers with Contributor-level access and above to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.Recommendations
For versions up to, and including, 5.9.22, update to a version higher than 5.9.22 to resolve the issue. As a temporary workaround, consider restricting access to the
get manual calendar events function until a patch is available. Additionally, ensure that all user input is properly sanitized and validated to prevent malicious script injections. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾