PT-2024-35133

CVE-2024-5221

·

تاريخ النشر

2024-06-06

·

تاريخ التحديث

2024-06-11

الوصف من

CVSS 3.1
6.4
متوسطة
المقاييسAV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions Qi Blocks plugin for WordPress versions up to, and including, 1.2.9
Description The Qi Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's file uploader due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Recommendations For Qi Blocks plugin for WordPress versions up to, and including, 1.2.9, update to a version higher than 1.2.9 to resolve the issue. As a temporary workaround, consider disabling the file uploader feature in the Qi Blocks plugin until a patch is available. Restrict access to the plugin's file uploader to minimize the risk of exploitation, allowing only trusted users with necessary permissions to access the feature.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾