PT-2024-35572
CVE-2024-53108
·
تاريخ النشر
2024-11-11
·
تاريخ التحديث
2026-10-18
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.65
Description
The issue is caused by the ID extraction happening outside of the range of the edid length in the AMD EDID, leading to out-of-bounds issues when using KASAN. This results in a slab-out-of-bounds error in the amdgpu dm update freesync caps function. The problem is addressed by considering the amd vsdb block size.
Recommendations
To resolve the issue, update to Linux kernel version 6.6.65 or later. As a temporary workaround, consider disabling the
amdgpu dm update freesync caps function until a patch is available. Restrict access to the vulnerable module to minimize the risk of exploitation. Avoid using the amd vsdb block size in the affected API endpoint until the issue is resolved. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾