PT-2024-36934

CVE-2024-56625

·

تاريخ النشر

2024-11-21

·

تاريخ التحديث

2026-10-21

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Linux kernel versions prior to 6.6.74
Description A vulnerability in the Linux kernel has been resolved, related to the can set termination() function, which allows sleeping GPIOs. The issue arose from the use of gpiod set value() to set the GPIO, leading to a warning when the system uses a sleeping GPIO, such as one behind an I2C port expander. The warning occurs at /drivers/gpio/gpiolib.c:3496 in the gpiod set value+0x50/0x6c function. The fix involves replacing gpiod set value() with gpiod set value cansleep() to allow the use of sleeping GPIOs.
Recommendations For Linux kernel versions prior to 6.6.74, update to version 6.6.74 or later to resolve the issue. As a temporary workaround, consider replacing gpiod set value() with gpiod set value cansleep() in the affected code to allow the use of sleeping GPIOs.
قابلية الاستغلال
استغلال
إصلاح
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
CLSA-2026-1786350974
CLSA-2026-1786352940
DLA-4076-1
MGASA-2025-0030
MGASA-2025-0032
OESA-2025-1286
OESA-2025-1450
OPENSUSE-SU-2025_0428-1
OPENSUSE-SU-2025_0499-1
OPENSUSE-SU-2025_0557-1
SUSE-SU-2025:0289-1
SUSE-SU-2025:0428-1
SUSE-SU-2025_0428-1
SUSE-SU-2025:0499-1
SUSE-SU-2025_0499-1
SUSE-SU-2025:0557-1
SUSE-SU-2025_0557-1
SUSE-SU-2025:20165-1
SUSE-SU-2025:20166-1
SUSE-SU-2025:20248-1
SUSE-SU-2025:20249-1
USN-7379-1
USN-7379-2
USN-7380-1
USN-7381-1
USN-7382-1
USN-7387-1
USN-7387-2
USN-7387-3
USN-7388-1
USN-7389-1
USN-7390-1
USN-7407-1
USN-7421-1
USN-7449-1
USN-7449-2
USN-7450-1
USN-7451-1
USN-7452-1
USN-7453-1
USN-7458-1
USN-7459-1
USN-7459-2
USN-7468-1
USN-7523-1
USN-7524-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾