PT-2024-36960
CVE-2024-56650
·
تاريخ النشر
2024-11-28
·
تاريخ التحديث
2026-10-21
الوصف من
CVSS 3.1
7.1
عاليةالمقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 6.6.74
Description
A vulnerability has been resolved in the Linux kernel, specifically in the netfilter: x tables module, where an invalid byte sequence may be passed from userspace, potentially leading to a slab-out-of-bounds error in the
strlen function. The led tg check function has been updated to include an extra check to ensure that such sequences are rejected as possible IDs and never passed to kstrdup or further. The issue was reported by Syzbot and detected by KASAN.Recommendations
To resolve the issue, update to Linux kernel version 6.6.74 or later. As a temporary workaround, consider restricting access to the vulnerable
led tg check function until a patch is available. Avoid using the kstrdup function with unvalidated user input in the affected API endpoint until the issue is resolved.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾