PT-2024-38752

CVE-2024-8013

·

تاريخ النشر

2024-10-28

·

تاريخ التحديث

2025-03-26

الوصف من

CVSS 3.1
3.3
منخفضة
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions: mongocryptd versions prior to 5.0.29 mongocryptd versions prior to 6.0.17 mongocryptd versions prior to 7.0.12 mongocryptd versions prior to 7.3.4 mongo crypt v1.so shared libraries versions prior to 6.0.17 mongo crypt v1.so shared libraries versions prior to 7.0.12 mongo crypt v1.so shared libraries versions prior to 7.3.4
Description: A bug in query analysis of certain complex self-referential $lookup subpipelines may result in literal values in expressions for encrypted fields to be sent to the server as plaintext instead of ciphertext. Should this occur, no documents would be returned or written.
Recommendations: For mongocryptd versions prior to 5.0.29, update to version 5.0.29 or later. For mongocryptd versions prior to 6.0.17, update to version 6.0.17 or later. For mongocryptd versions prior to 7.0.12, update to version 7.0.12 or later. For mongocryptd versions prior to 7.3.4, update to version 7.3.4 or later. For mongo crypt v1.so shared libraries versions prior to 6.0.17, update to version 6.0.17 or later. For mongo crypt v1.so shared libraries versions prior to 7.0.12, update to version 7.0.12 or later. For mongo crypt v1.so shared libraries versions prior to 7.3.4, update to version 7.3.4 or later.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2024-15966
ALT-PU-2024-16016
ALT-PU-2024-16032
ALT-PU-2024-16036
ALT-PU-2024-16066
ALT-PU-2024-16107
ALT-PU-2024-16109
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾