PT-2024-4536
CVE-2023-46045
·
تاريخ النشر
2024-01-26
·
تاريخ التحديث
2026-09-29
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Graphviz versions 2.36.0 through 9.x before 10.0.1
Graphviz versions 2.36 before 10.0.0
Description:
The issue is related to an out-of-bounds read in the Graphviz application, which can be exploited via a crafted config6a file. This may allow an attacker to execute arbitrary code. The exploitability may be uncommon because the config6a file is typically owned by root.
Recommendations:
For Graphviz versions 2.36.0 through 9.x before 10.0.1, update to version 10.0.1 or later to resolve the issue.
For Graphviz versions 2.36 before 10.0.0, update to version 10.0.0 or later to resolve the issue.
As a temporary workaround, consider restricting access to the config6a file to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾